Routage Statique

Le routage statique permet de rajouter des informations dans la table de routage de façon manuel.

Route = Par ou je passe pour joindre ce réseau ?
Table de routage = Endroit où notre routeur stocke toutes les informations concernant le routage.

 

Présentation des routeurs


Objectif d’un routeur : Distribuer les paquets IP sur le réseau.

À quoi peut-on comparer un routeur : au facteur de votre quartier

Il connait les adresses de son secteur et peut donc directement livrer ses paquets.
– Il sait que pour les autres quartiers, ville et pays, il faudra donner le paquet à son centre de tri.
Ce qui se passe après ? Cela ne le regarde pas, ce n’est pas son boulot !

Un routeur remonte jusq’à quel couche du modèle OSI ?

– Jusqu’à la couche 3 (IP).

Petites particularités concernant les routeurs : 

– Un routeur ne peux pas avoir deux interfaces dans le même réseau.
– Toutes les interfaces d’un routeur sont shutdown par défaut.

 

 

Principe de fonctionnement


BOB veut joindre ALICE

Que se passe-t-il lorsque BOB veut échanger des informations avec ALICE :

BOB veut joindre ALICE.
ALICE n’est pas dans le même réseau IP que BOB.
BOB envoie donc ses paquets à sa gateway (passerelle par défaut).
– La gateway de BOB est l’adresse IP du routeur R1.
– Le travail du routeur R1 est de trouver une solution pour joindre ALICE.

Que vas faire R1 ?

Que va faire R1 ?

Ce que va faire le routeur R1 :

Le routeur R1 reçoit un

R10 sait comment joindre ALICE.
R20 sait comment joindre PIERRE et PAUL.
R30 sait comment joindre JACQUES.

Comment se remplit une table de routage ?

Pour ce faire, trois façons :

Par déduction
Si une de mes interfaces est dans le réseau 10.10.10.0/24, c’est que je sais comment le joindre.

Manuellement
Via des lignes de commandes

Dynamiquement
Via des protocoles de routages dynamiques comme RIP, OSPF, EIGRP et BGP.

 

Apprentissage par déduction


Apprentissage par déduction

Apprentissage par déduction

 

Configuration


R1(config)# interface FastEthernet 0/0
R1(config-if)# ip address 10.10.10.254 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# interface FastEthernet 0/1
R1(config-if)# ip address 20.20.20.254 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# interface FastEthernet 0/2
R1(config-if)# ip address 30.30.30.254 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

 

Vérification de la table de routage


R1# show ip route

Gateway of last resort is not set

C       10.10.10.0 is directly connected, FastEthernet0/1
C       20.20.20.0 is directly connected, FastEthernet0/2
C       30.30.30.0 is directly connected, FastEthernet0/3

Notre routeur sait comment joindre ces trois réseaux !

Exercice Packet Tracer


Packet Tracer – Routage Statique – Connected

 

Apprentissage Manuel


Apprentissage des routes manuellement

Apprentissage des routes manuellement

 

Configuration de base


R1(config)# interface FastEthernet 0/0
R1(config-if)# description LAN
R1(config-if)# ip address 10.10.10.254 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# interface FastEthernet 0/1
R1(config-if)# description WAN
R1(config-if)# ip address 1.1.1.1 255.255.255.248
R1(config-if)# no shutdown
R1(config-if)# exit
R2(config)# interface FastEthernet 0/0
R2(config-if)# description LAN
R2(config-if)# ip address 20.20.20.254 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit

R2(config)# interface FastEthernet 0/1
R2(config-if)# description WAN
R2(config-if)# ip address 1.1.1.2 255.255.255.248
R2(config-if)# no shutdown
R2(config-if)# exit

 

Vérification


R1# show ip route

Gateway of last resort is not set

C       10.10.10.0 is directly connected, FastEthernet0/0
C       1.1.1.0    is directly connected, FastEthernet0/1
R2# show ip route

Gateway of last resort is not set

C       20.20.20.0 is directly connected, FastEthernet0/0
C       1.1.1.0    is directly connected, FastEthernet0/1

Problématique :

R1 ne sait pas comment joindre le réseau 20.20.20.0/24
R2 ne sait pas comment joindre le réseau 10.10.10.0/24

Solution :

!!! Configurer des routes statiques !!!

 

Configuration du routage statique


R1(config)# ip route 20.20.20.0 255.255.255.0 1.1.1.2 name LAN_R2
R2(config)# ip route 10.10.10.0 255.255.255.0 1.1.1.1 name LAN_R1

 

Vérification


R1# show ip route

Gateway of last resort is not set

C       10.10.10.0 is directly connected, FastEthernet0/0
S       20.20.20.0/24 [1/0] via 1.1.1.2 
C       1.1.1.0    is directly connected, FastEthernet0/1

R2# show ip route

Gateway of last resort is not set

S       10.10.10.0/24 [1/0] via 1.1.1.1 
C       20.20.20.0 is directly connected, FastEthernet0/0
C       1.1.1.0    is directly connected, FastEthernet0/1

R1 et R2 connaissent maintenant les réseaux 10.10.10.0/24 et 20.20.20.0/24

 

Exercice Packet Tracer


Packet Tracer – Routage Statique

 

Apprentissage dynamique


… Ce sujet est très vaste !!!! Concentrons-nous dans un premier temps aux routes statiques !!!

 

Les routes statiques


Créer une route statique


 

R1(config)# ip route 192.168.1.0 255.255.255.0 1.1.1.2 name Agence_1

ou

R1(config)# ip route 192.168.1.0 255.255.255.0 FastEthernet 1/0 name Agence_1

192.168.1.0 = Réseau de destination
255.255.255.0 = masque
1.1.1.2 = Adresse IP du routeur voisin
FastEthernet 1/0 = Interface Ethernet où est branché le routeur voisin.

Nous avons donc dit à notre routeur que le réseau 192.168.1.0 /24 est disponible via le routeur ayant comme adresse 1.1.1.2 Cette adresse doit être directement connecté au routeur.

Name = Comme je l’ai dit dans mes articles précédents , les descriptions sont importantes !! Aujourd’hui vous savez qui correspond à quoi. Demain ce sera un autre administrateur qui va venir sur votre équipement actif, et si vous avez 30 routes statiques, bah il sera perdu !!!

 

Supprimer une route statique


Il suffit juste de rajouter un « no » devant notre route statique

R1(config)# no ip route 192.168.1.0 255.255.255.0 1.1.1.2 name Agence_1

 

Route par défaut


 

R1(config)# ip route 0.0.0.0 0.0.0.0 2.2.2.1 name DEFAULT_GATEWAY

Le réseau 0.0.0.0 /0 englobe toutes les adresses possibles en IPv4. Tout le monde va être redirigé vers l’adresse 2.2.2.1 s’il n’y a pas d’autres solutions.

 

Table de routage


Pour visualiser la table de routage , entrez la commande

Router# show ip route 
Résultat :
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 2.2.2.1 to network 0.0.0.0

1.1.1.0/24 is subnetted, 1 subnets

C 1.1.1.0 is directly connected, FastEthernet1/0
S 192.168.1.0/24 [1/0] via 1.1.1.2
C 192.168.0.0/24 is directly connected, FastEthernet2/0
S* 0.0.0.0/0 [1/0] via 2.2.2.1

 

Comment notre équipement choisit la meilleure route ?


 

Étape 1 : Administrative distance


Nous avons vu précédemment que nos routeurs interrogent leurs tables de routages pour savoir à quel routeur distribuer les paquets reçus. Dans cette table de routage, il y a une chose importante qui est prise en compte : La Distance administrative.

Cette valeur comprise entre 0 et 255 permet de savoir quelle route choisir si notre table de routage nous indique plusieurs chemins possibles.
La Distance administrative prioritaire est la 0.
La Distance administrative qui sera choisie dans le pire des cas sera la 255.

Routage dynamique - Administrative distance

Routage dynamique – Administrative distance

 

Étape 2 : Masque le plus restrictif


Conditions :
– Administrative Distance identique !

Imaginons que nous avons les deux routes statiques suivantes :

R1(config)# ip route 192.168.0.0 255.255.255.0 1.1.1.1 name VERS_R1
R1(config)# ip route 192.168.0.0 255.255.0.0 2.2.2.1 name VERS_R2

Notre routeur doit router un paquet vers l’adresse 192.168.0.1
Ce paquet vas être envoyé vers R1 ou R2 ?
Il va être envoyé vers R1 vu que le masque /24 (255.255.255.0) est plus restrictif que le masque /16 (255.255.0.0)

 

Étape 3 : En cas d’égalité


Conditions :
– Administrative Distance identique !
– Masque de sous réseau identique !

Résultat :
– Load Balancing

Conclusion


– Nommez vos route !
– Prenez en compte les distances administratives.

 

En espérant que cet article vous a été utile ! N’hésitez pas à me la faire savoir !!
Ce site possède d’autres articles réseau, profitez-en pour naviguer dans la barre de menu !

 

FingerInTheNet.com

Noël NICOLAS

Expert Réseau
10 ans d’expérience
CCNP Routing and Switching
Fondateur du site FingerInTheNet

6
Poster un Commentaire

Laisser un commentaire

  Subscribe  
plus récents plus anciens plus de votes
Me notifier des
Brice
Invité
Brice

Salut NICOLAS,

Dans un livre préparant à la certification CCNA 200-125, l’auteur a abordé certains concepts concernant le routage statique dont j’ai pas bien saisi la quintessence. il s’agit de « Static Routes with no competing Routes » et « Static Routes with competing Routes ». Tu peux nous en dire Plus.

Merci pour ton apport .

KayouMT
Invité
KayouMT

Excellent !

1 – Je suggére d’ajouter une courte explication des lettres qui se trouvent à gauche des routes : C, S, S*, …

2 – Ça serait aussi intéressant de voir le résultat de « sh ip route » dans le cas où une route satique a le même next hop qu’une default route.