Routage Inter-Vlan

 

Objectifs pédagogiques


Les objectifs pédagogiques de cette leçon sont :

– Mettre en place du routage vlan.
Faire communiquer différents Vlans.
– Connaître les solutions ROAS et SVI.

 

Présentation


Comme vu précédemment dans l’article Vlan :

1 Vlan = 1 réseau IP
Exemple : Vlan 10 = 192.168.10.0/24.

Si un ordinateur veut, discuter avec une adresse IP qui ne fait pas partit de son réseau, il devra passer par sa Passerelle par défaut ( Gateway en anglais ).

Qui va nous permettre de faire communiquer plusieurs réseaux différents ? Un Routeur !!

Notre routeur va donc porter toutes les passerelles par défaut de nos Vlans.

Il existe 3 méthodes pour faire communiquer deux Vlans :

– La méthode préhistorique.
– La méthode Router On a Stick (ROAS).
– La méthode Switch Virtual Interface (SVI).

 

 

Le routage inter-vlan préhistorique


Architecture

Architecture

 

Notre routeur va servir à faire du routage inter-vlan.

Pour faire du routage inter-vlan, il faut qu’il soit dans tous les Vlans à la fois.

Nous allons donc lui mettre une patte physique dans chaque Vlan :

– Si nous avons 3 Vlans , il faudra réserver 3 ports sur notre Switch et 3 ports sur notre routeur.
– Si nous avons 500 Vlans, il faudra réserver 500 ports sur notre Switch et 500 ports sur notre routeur.

 

Configuration du Switch


SWE_01(config)# interface FastEthernet 0/1
SWE_01(config-if)# descrpition VERS_RO_01_FA_01
SWE_01(config-if)# switchport mode access
SWE_01(config-if)# switchport access vlan 10
SWE_01(config-if)# exit

SWE_01(config)# interface FastEthernet 0/2
SWE_01(config-if)# descrpition VERS_RO_01_FA_02
SWE_01(config-if)# switchport mode access
SWE_01(config-if)# switchport access vlan 20
SWE_01(config-if)# exit

SWE_01(config)# interface FastEthernet 0/3
SWE_01(config-if)# descrpition VERS_RO_01_FA_03
SWE_01(config-if)# switchport mode access
SWE_01(config-if)# switchport access vlan 30
SWE_01(config-if)# exit

 

Configuration du Routeur


RO_01(config)# interface FastEthernet 0/1
RO_01(config-if)# description VLAN_SECRETAIRE
RO_01(config-if)# ip address 192.168.10.254 255.255.255.0
RO_01(config-if)# encapsulation dot1q 10
RO_01(config-if)# no shutdown
RO_01(config-if)# exit

RO_01(config)# interface FastEthernet 0/2
RO_01(config-if)# description VLAN_BOSS
RO_01(config-if)# ip address 192.168.20.254 255.255.255.0
RO_01(config-if)# encapsulation dot1q 20
RO_01(config-if)# no shutdown 
RO_01(config-if)# exit

RO_01(config)# interface FastEthernet 0/3
RO_01(config-if)# description VLAN_VENDEUR
RO_01(config-if)# ip address 192.168.30.254 255.255.255.0
RO_01(config-if)# encapsulation dot1q 30
RO_01(config-if)# no shutdown 
RO_01(config-if)# exit

Cette méthode est complètement obsolète, mais il est important de savoir qu’elle existe !

 

Le routage inter-vlan Router On A Stick ( ROAS )


Architecture ROAS

Architecture ROAS

1 Vlan = 1 interface physique sur notre routeur c’est impensable.

Il fallait trouver une solution pour pallier à ça ! La solution c’est les « sous-interface » !!!

Router(config)# interface FastEthernet 0/0.?
<0-4294967295> FastEthernet interface number

Nous pouvons donc créer 4 294 967 295 sous-interfaces soit 4,2 milliards de possibilités !

Chaque sous-interface peut se configurer comme une interface normale ! on peut donc leur appliquer la même configuration vue plus haut.

La configuration de notre switch va aussi changer. Le port d’interconnexion devrait être configuré en Trunk.

 

Configuration du Switch


SWE_01(config)# interface FastEthernet 0/24
SWE_01(config-if)# description TRUNK_VERS_RO_01
SWE_01(config-if)# switchport mode trunk
SWE_01(config-if)# switchport trunk encapsulation dot1q

 

Configuration du Routeur


RO_01(config)# interface FastEthernet 0/0
RO_01(config-if)# description VERS_SWE_01
RO_01(config-if)# no shutdown
RO_01(config-if)# exit

RO_01(config)# interface FastEthernet 0/0.10
RO_01(config-subif)# description VLAN_SECRETAIRE
RO_01(config-subif)# ip address 192.168.10.254 255.255.255.0
RO_01(config-subif)# encapsulation dot1q 10
RO_01(config-subif)# exit

RO_01(config)# interface FastEthernet 0/0.20
RO_01(config-subif)# description VLAN_BOSS
RO_01(config-subif)# ip address 192.168.20.254 255.255.255.0
RO_01(config-subif)# encapsulation dot1q 20
RO_01(config-subif)# exit

RO_01(config)# interface FastEthernet 0/0.30
RO_01(config-subif)# description VLAN_VENDEUR
RO_01(config-subif)# ip address 192.168.30.254 255.255.255.0
RO_01(config-subif)# encapsulation dot1q 30
RO_01(config-subif)# exit

 

Exercice Packet Tracer


Packet Tracer – Routage InterVlan – ROAS

 

Le routage inter-vlan Switch Virtual Interface ( SVI )


Architecture SVI

Architecture SVI

 

Activer le routage sur le Switch


SWC_01(config)# ip routing

 

Configuration du port d’interconnexion


SWC_01(config)# interface FastEthernet 0/1
SWC_01(config-if)# description VERS_SWITCH_SWE_01
SWC_01(config-if)# switchport mode trunk
SWC_01(config-if)# switchport trunk encapsulation dot1q

 

Configuration des interfaces Vlans


SWC_01(config)# interface vlan 10
SWC_01(config-vlan)# description VLAN_SECRETAIRE
SWC_01(config-vlan)# ip address 192.168.10.254 255.255.255.0
SWC_01(config-vlan)# exit

SWC_01(config)# interface vlan 20
SWC_01(config-vlan)# description VLAN_BOSS
SWC_01(config-vlan)# ip address 192.168.20.254 255.255.255.0
SWC_01(config-vlan)# exit

SWC_01(config)# interface vlan 30
SWC_01(config-vlan)# description VLAN_VENDEUR
SWC_01(config-vlan)# ip address 192.168.30.254 255.255.255.0
SWC_01(config-vlan)# exit

 

Exercice Packet Tracer


Packet Tracer – Routage InterVlan – SVI

 

Conclusion


Comparatif des solutions

Comparatif des solutions

Privilégiez le Routage SVI !!!

Noël NICOLAS

Expert Réseau
10 ans d’expérience
CCNP Routing and Switching
Fondateur du site FingerInTheNet

3
Poster un Commentaire

Laisser un commentaire

  Subscribe  
plus récents plus anciens plus de votes
Me notifier des
Vivien
Invité
Vivien

Très bon article 🙂